Accessibility Links

What are the system requirements?

You can watch on PCs running Windows 7+, and Intel-based Macs running OSX 10.12+. You can also watch on Android tablets and phones using Chrome and on iPhones and iPads using Safari. Linux devices are not supported and will not work. You will need a broadband or fibre internet connection - dial up will not work. You’ll find a complete list of requirements below.

What are the requirements for Windows computers?

Windows 7, Windows 8.1 or Windows 10. Google Chrome, Firefox, Microsoft Edge, Internet Explorer or Opera. We recommend using the latest version of your browser as earlier versions may not be supported. Internet Explorer on Windows 7 is no longer supported. You will need a broadband or fibre internet connection - dial up will not work.

What are the requirements for Mac computers?

Mac OSX 10.12 or later. Google Chrome, Firefox, Safari, or Opera. We recommend using the latest version of your browser as earlier versions may not be supported. You will need a broadband or fibre internet connection - dial up will not work.

Can I watch on my Linux device?

No, unfortunately due to the level of protection on the content, our player doesn’t support playback on linux platforms.

Can I watch content on my iPhone/iPad?

Yes, you can watch content using Safari and this requires iOS 11.2 or later. We recommend using the latest version of your browser as earlier versions may not be supported.

Can I watch content on my Android Device?

Yes, you can watch content using Chrome and this requires Android 6.0 or later. We recommend using the latest version of your browser as earlier versions may not be supported.

Download the app to view your purchased content!